summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Storsjo <martin@martin.st>2012-06-28 14:42:48 +0300
committerMartin Storsjo <martin@martin.st>2012-07-11 14:28:02 +0300
commitcd1c375de07eee2c22fcec83a20306a239910525 (patch)
tree963e7a5d5dcfe7b325af6474fc106ccf9872ab43 /configure.ac
parent2bda038c163298531d47394bc2c09e1409c5d0db (diff)
downloadODR-AudioEnc-cd1c375de07eee2c22fcec83a20306a239910525.tar.gz
ODR-AudioEnc-cd1c375de07eee2c22fcec83a20306a239910525.tar.bz2
ODR-AudioEnc-cd1c375de07eee2c22fcec83a20306a239910525.zip
Add automake/autoconf source files
Change-Id: If97c7482bffaab4a21cd2fb8341f2939f19d3bbd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..e9b1b9c
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,29 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_INIT([fdk-aac], [0.1.0], [http://sourceforge.net/projects/opencore-amr/])
+AC_CONFIG_AUX_DIR(.)
+AC_CONFIG_MACRO_DIR([m4])
+AM_INIT_AUTOMAKE([tar-ustar])
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+AC_CONFIG_HEADERS([config.h])
+
+# Cross compiling support
+AC_CANONICAL_HOST
+
+# Checks for programs.
+AC_PROG_CXX
+
+# Setup for libtool
+AC_PROG_LIBTOOL
+AC_SUBST(LIBTOOL_DEPS)
+
+# soname version to use
+# goes by ‘current[:revision[:age]]’ with the soname ending up as
+# current.age.revision.
+FDK_AAC_VERSION=0:1:0
+AC_SUBST(FDK_AAC_VERSION)
+
+AC_CONFIG_FILES([Makefile
+ fdk-aac.pc])
+AC_OUTPUT