summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2019-08-21 10:08:51 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2019-08-21 10:08:51 +0200
commitfa5f92318e7cc08ac872be18d47387cf83c23cd0 (patch)
tree118b12cf95b478fd20916f745c0d1a7873e16040 /Makefile.am
parent781c2c69c62a434bed64ff3cfa6d009ed3c479c1 (diff)
downloadODR-AudioEnc-fa5f92318e7cc08ac872be18d47387cf83c23cd0.tar.gz
ODR-AudioEnc-fa5f92318e7cc08ac872be18d47387cf83c23cd0.tar.bz2
ODR-AudioEnc-fa5f92318e7cc08ac872be18d47387cf83c23cd0.zip
Add tist support for EDI output, take code from odr-mmbtools-common
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 9a45a0b..0105831 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -104,24 +104,30 @@ odr_audioenc_SOURCES = src/odr-audioenc.cpp \
src/utils.h \
src/wavfile.cpp \
src/common.h \
+ contrib/ClockTAI.cpp \
+ contrib/ClockTAI.h \
+ contrib/RemoteControl.cpp \
+ contrib/RemoteControl.h \
+ contrib/Log.cpp \
+ contrib/Log.h \
contrib/Socket.cpp \
contrib/Socket.h \
+ contrib/crc.c \
+ contrib/crc.h \
+ contrib/ReedSolomon.cpp \
+ contrib/ReedSolomon.h \
+ contrib/ThreadsafeQueue.h \
contrib/edi/AFPacket.cpp \
contrib/edi/AFPacket.h \
contrib/edi/Config.h \
- contrib/edi/crc.c \
- contrib/edi/crc.h \
contrib/edi/Interleaver.cpp \
contrib/edi/Interleaver.h \
contrib/edi/PFT.cpp \
contrib/edi/PFT.h \
- contrib/edi/ReedSolomon.cpp \
- contrib/edi/ReedSolomon.h \
contrib/edi/TagItems.cpp \
contrib/edi/TagItems.h \
contrib/edi/TagPacket.cpp \
contrib/edi/TagPacket.h \
- contrib/edi/ThreadsafeQueue.h \
contrib/edi/Transport.cpp \
contrib/edi/Transport.h \
$(FEC_SOURCES)