summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2019-07-03 15:48:30 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2019-07-03 15:48:30 +0200
commit36219517c52ad97ab96545c9289b82890861d77b (patch)
tree7d1f73ac9c3c0009df86ef4210ecba6f39b90bd8 /Makefile.am
parente7a9a94fb8ebd50e10ed403ef871620181d3aa1d (diff)
downloadODR-AudioEnc-36219517c52ad97ab96545c9289b82890861d77b.tar.gz
ODR-AudioEnc-36219517c52ad97ab96545c9289b82890861d77b.tar.bz2
ODR-AudioEnc-36219517c52ad97ab96545c9289b82890861d77b.zip
Enable -Wall and fix a few warnings
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 05136ba..9a45a0b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,8 +78,8 @@ odr_audioenc_LDADD = libtoolame-dab.la \
$(odr_audioenc_LDADD_JACK) \
$(odr_audioenc_LDADD_ALSA) \
$(LIBVLC_LIBS) $(LIBFDKAAC_LIBS)
-odr_audioenc_CPPFLAGS = $(AM_CPPFLAGS) $(LIBFDKAAC_CFLAGS) $(GITVERSION_FLAGS) \
- -ggdb -O2 -Isrc -Icontrib
+odr_audioenc_CXXFLAGS = $(LIBFDKAAC_CFLAGS) $(GITVERSION_FLAGS) \
+ -Wall -ggdb -O2 -Isrc -Icontrib
odr_audioenc_SOURCES = src/odr-audioenc.cpp \
src/FileInput.cpp \