summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2016-07-08 11:50:26 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2016-07-08 11:50:26 +0200
commit64b729f3284ead6a71fbeb7f8e0dd22187b21786 (patch)
tree60efb272d174f31bb93cfe561ac1c7ceeb3b412e /Makefile.am
parent561b6adce76dd209ebc547fcd98f525501742d97 (diff)
downloadODR-AudioEnc-64b729f3284ead6a71fbeb7f8e0dd22187b21786.tar.gz
ODR-AudioEnc-64b729f3284ead6a71fbeb7f8e0dd22187b21786.tar.bz2
ODR-AudioEnc-64b729f3284ead6a71fbeb7f8e0dd22187b21786.zip
Add doxygen configuration and target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 629ee12..a71f2ae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -308,6 +308,7 @@ EXTRA_DIST = \
$(top_srcdir)/Android.mk \
$(top_srcdir)/fdk-dabplus.sym \
$(top_srcdir)/libtoolame-dab.sym \
+ $(top_srcdir)/Doxyfile \
$(top_srcdir)/documentation/*.pdf \
$(top_srcdir)/libAACdec/src/*.h \
$(top_srcdir)/libAACdec/src/arm/*.cpp \
@@ -334,3 +335,8 @@ EXTRA_DIST = \
$(top_srcdir)/libFDK/src/arm/*.cpp \
$(top_srcdir)/libFDK/src/mips/*.cpp
+doc: export PROJECT_NUMBER:=$(shell git describe --dirty)
+
+.PHONY: doc
+doc:
+ doxygen