summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2015-05-04 11:16:28 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2015-05-04 11:16:59 +0200
commit6ed3918317cb9b20ece88a46daaccc52d974b7bd (patch)
treef95bf412f06260e20c62aa7fa799f42554105283 /Makefile.am
parent957f67c0a5bf831ff743d03548e515ddc450e8cc (diff)
downloadODR-AudioEnc-6ed3918317cb9b20ece88a46daaccc52d974b7bd.tar.gz
ODR-AudioEnc-6ed3918317cb9b20ece88a46daaccc52d974b7bd.tar.bz2
ODR-AudioEnc-6ed3918317cb9b20ece88a46daaccc52d974b7bd.zip
Replace boost by C++11
std::thread doesn't support interruption like boost::thread, which was used in the ALSA input. Everything else should be equivalent.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7dd97ce..180601d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,7 +44,7 @@ libfdk_aac_la_LDFLAGS = -version-info @FDK_AAC_VERSION@ -no-undefined \
# src/wavreader.c
if HAVE_JACK
-dabplus_enc_LDADD_JACK = -ljack -lpthread
+dabplus_enc_LDADD_JACK = -ljack
else
dabplus_enc_LDADD_JACK =
endif
@@ -52,7 +52,7 @@ endif
dabplus_enc_LDFLAGS = -no-install
dabplus_enc_LDADD = libfdk-aac.la -lfec -lzmq -lasound \
- -lrt -lboost_thread $(dabplus_enc_LDADD_JACK) \
+ -lrt $(dabplus_enc_LDADD_JACK) \
$(LIBVLC_LIBS)
dabplus_enc_CPPFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS) -ggdb -O2
dabplus_enc_SOURCES = src/dabplus-enc.cpp \