summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2014-06-26 20:16:37 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2014-06-26 20:16:37 +0200
commit45613a2ac14272c3e4779dd9aa971b5160bb060e (patch)
treeffec3e9f2e213415a3755849f0feaa53ea5101ad /Makefile.am
parentc0ec1e01c7dd84ce694bc5268916cc43870f00cf (diff)
downloadODR-AudioEnc-45613a2ac14272c3e4779dd9aa971b5160bb060e.tar.gz
ODR-AudioEnc-45613a2ac14272c3e4779dd9aa971b5160bb060e.tar.bz2
ODR-AudioEnc-45613a2ac14272c3e4779dd9aa971b5160bb060e.zip
Add JACK input support
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b807cd3..89186f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,15 +43,24 @@ libfdk_aac_la_LDFLAGS = -version-info @FDK_AAC_VERSION@ -no-undefined \
#aac_enc_SOURCES = src/aac-enc.c \
# src/wavreader.c
+if HAVE_JACK
+dabplus_enc_LDADD_JACK = -ljack -lpthread
+else
+dabplus_enc_LDADD_JACK =
+endif
+
+
dabplus_enc_LDFLAGS = -no-install
dabplus_enc_LDADD = libfdk-aac.la -lfec -lzmq -lasound \
- -lrt -lboost_thread
-dabplus_enc_CPPFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS)
+ -lrt -lboost_thread $(dabplus_enc_LDADD_JACK)
+dabplus_enc_CPPFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS) -ggdb
dabplus_enc_SOURCES = src/dabplus-enc.cpp \
src/FileInput.cpp \
src/FileInput.h \
src/AlsaInput.cpp \
src/AlsaInput.h \
+ src/JackInput.cpp \
+ src/JackInput.h \
src/SampleQueue.h \
src/encryption.c \
src/encryption.h \