summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2015-03-11 21:15:38 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2015-03-11 21:15:38 +0100
commit58378f49c75b7c6e184c499082328761b468da68 (patch)
treedf16e70225672ea19fb1df01f2af40aaae67dfaa /Makefile.am
parent599d0fc5892725e471772e567555bf075ad2ae86 (diff)
downloadODR-AudioEnc-58378f49c75b7c6e184c499082328761b468da68.tar.gz
ODR-AudioEnc-58378f49c75b7c6e184c499082328761b468da68.tar.bz2
ODR-AudioEnc-58378f49c75b7c6e184c499082328761b468da68.zip
Add libvlc input
Be careful about sample rate conversion, VLC only wants to use the ugly resampler on some machines.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8d8f54e..e1449d3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,7 +52,8 @@ endif
dabplus_enc_LDFLAGS = -no-install
dabplus_enc_LDADD = libfdk-aac.la -lfec -lzmq -lasound \
- -lrt -lboost_thread $(dabplus_enc_LDADD_JACK)
+ -lrt -lboost_thread $(dabplus_enc_LDADD_JACK) \
+ $(LIBVLC_LIBS)
dabplus_enc_CPPFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS) -ggdb
dabplus_enc_SOURCES = src/dabplus-enc.cpp \
src/FileInput.cpp \
@@ -61,6 +62,8 @@ dabplus_enc_SOURCES = src/dabplus-enc.cpp \
src/AlsaInput.h \
src/JackInput.cpp \
src/JackInput.h \
+ src/VLCInput.cpp \
+ src/VLCInput.h \
src/SampleQueue.h \
src/encryption.c \
src/encryption.h \