summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2014-06-16 21:46:12 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2014-06-16 22:17:53 +0200
commit32068fb8bdc602b5835dbe4e507e34150395a9f8 (patch)
tree313bc8c6e50f2f6eeaa59f3e0bbc6d11788396e2 /Makefile.am
parent22c3e7527db44f201f0362506fcf6ab5d648f983 (diff)
downloadODR-AudioEnc-32068fb8bdc602b5835dbe4e507e34150395a9f8.tar.gz
ODR-AudioEnc-32068fb8bdc602b5835dbe4e507e34150395a9f8.tar.bz2
ODR-AudioEnc-32068fb8bdc602b5835dbe4e507e34150395a9f8.zip
Make mot-encoder C++, removes memory leaks
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f698249..b807cd3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,9 +60,9 @@ dabplus_enc_SOURCES = src/dabplus-enc.cpp \
src/utils.h \
src/wavreader.c
-mot_encoder_CFLAGS = $(GITVERSION_FLAGS) @MAGICKWAND_CFLAGS@ -Icontrib
+mot_encoder_CXXFLAGS = $(GITVERSION_FLAGS) @MAGICKWAND_CFLAGS@ -Icontrib
mot_encoder_LDADD = @MAGICKWAND_LDADD@
-mot_encoder_SOURCES = src/mot-encoder.c \
+mot_encoder_SOURCES = src/mot-encoder.cpp \
contrib/lib_crc.h \
contrib/lib_crc.c