summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Storsjo <martin@martin.st>2012-06-29 12:00:35 +0300
committerMartin Storsjo <martin@martin.st>2012-07-11 14:28:03 +0300
commit4f7355002c8b88d62362179eb792c712d4056dca (patch)
tree04f607d4789828a7c9cf041cb87ba96601349f1d /Makefile.am
parentb431d100a3582652dfd11b2e08ffb6c8f05bfd41 (diff)
downloadODR-AudioEnc-4f7355002c8b88d62362179eb792c712d4056dca.tar.gz
ODR-AudioEnc-4f7355002c8b88d62362179eb792c712d4056dca.tar.bz2
ODR-AudioEnc-4f7355002c8b88d62362179eb792c712d4056dca.zip
Don't link to libstdc++
While the source is C++, it doesn't use anything from the C++ runtime, so by building with -fno-exceptions -fno-rtti, the dynamic library doesn't have to be linked to libstdc++. This also simplifies things for users of the static library.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c5b320f..1c77b08 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,6 +11,11 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/libFDK/include \
-I$(top_srcdir)/libPCMutils/include
+AM_CXXFLAGS = -fno-exceptions -fno-rtti
+libfdk_aac_la_LINK = $(LINK) $(libfdk_aac_la_LDFLAGS)
+# Mention a dummy pure C file to trigger generation of the $(LINK) variable
+nodist_EXTRA_libfdk_aac_la_SOURCES = dummy.c
+
fdk_aacincludedir = $(includedir)/fdk-aac
fdk_aacinclude_HEADERS = \
$(top_srcdir)/libSYS/include/machine_type.h \