summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2014-04-19 00:37:19 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2014-04-19 00:37:19 +0200
commit66f40d1badeb945d60b76c182e7bee4b0fc4dd7b (patch)
tree82121e8a8fac6b552528a143db73c62d351a0200 /Makefile.am
parent915ead05ae048958101d46430d3eed292f1476cf (diff)
downloadODR-AudioEnc-66f40d1badeb945d60b76c182e7bee4b0fc4dd7b.tar.gz
ODR-AudioEnc-66f40d1badeb945d60b76c182e7bee4b0fc4dd7b.tar.bz2
ODR-AudioEnc-66f40d1badeb945d60b76c182e7bee4b0fc4dd7b.zip
Add ZMQ CURVE auth support
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a357778..b08b307 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,6 +47,8 @@ dabplus_enc_file_zmq_LDADD = libfdk-aac.la -lfec -lzmq
dabplus_enc_file_zmq_CFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS)
dabplus_enc_file_zmq_SOURCES = src/dabplus-enc-file-zmq.c \
src/wavreader.c \
+ src/encryption.c \
+ src/encryption.h \
contrib/lib_crc.h \
contrib/lib_crc.c
@@ -58,6 +60,8 @@ dabplus_enc_alsa_zmq_SOURCES = src/dabplus-enc-alsa-zmq.cpp \
src/AlsaInput.cpp \
src/AlsaInput.h \
src/SampleQueue.h \
+ src/encryption.c \
+ src/encryption.h \
src/zmq.hpp